Install Elasticsearch on Ubuntu


Active Member
I am running Ubuntu 18.04.3. I have updated Elasticsearch by adding the 7.x PPM, which is checked when doing apt-get update && apt-get upgrade updates (the Ubuntu equivalent to yum check-update or yum upgrade).

The PPA for Ubuntu for Elasticsearch is:


Active Member
When I recently updated my Elasticsearch 7.5.2 installation to 7.6.0, the system returned an error, noting that my current Java 8 installation would not work, and that a newer version of Java/JDK was required.

With Elasticsearch version 7.5.2 and below, you could use Java 8 and higher as the runtime environment. With ES 7.6.0 and higher, Java 11 or higher is seemingly required (at least, it was when I tried to update it on my forum).

This means that you must upgrade your Java environment (JDK) to Java 11 or higher. I did this by removing the Java 8 PPA from my Ubuntu list. It has not been updated since early 2019 anyway, because of Oracle’s licensing changes relating to Java. Java 11 is the latest LTS version of Java after Java 8, and Java 8 is no longer receiving updates from Oracle. I would not recommend using Java 9, 10 or 12, as they are not LTS (long-term supported) versions of Java/JDK.

I switched over to the OpenJDK environment and installed Java 11, by adding an appropriate PPA to my Ubuntu PPA list (also: see first command below). This works for Ubuntu, Debian and relates distros. Obviously things will be different for CentOS, RHEL and other non-Debian-based distros.

The commands to add the Java 11 OpenJDK PPA, and then to install Java 11, on Debian-based Linux distros, are:

add-apt-repository ppa:openjdk-r/ppa apt-get update apt install openjdk-11-jdk

The previous commands assume you are root. If not, please preface each command above with sudo

The URL that will appear in your PPA list to be checked with apt-get update && apt-get upgrade operations is:

After installing Java 11, and checking it with the command java -version you will find that ES 7.6.x will install just fine.

Screen Shot 2020-02-18 at 8.08.59 AM.jpg


It looks like this is already up to version 7.9.2 now.

This wouldn't install for me, but I'll contact the host today. I'm on a sub account of a shared reseller account, on a server full of other reseller accounts. (not a dedi or vps) It feels like my account has training wheels/restrictions.

The available memory looks ok, right?



Active Member
As far as I know, you can't install Elasticsearch on a shared hosting environment. It requires a VPS. This is per XenForo's documentation. You need to have enough control of the environment to be able to install Java and then the Elasticsearch software.


Yea that was pretty much what the provider said, too. :) I tried it myself before contacting them, with no luck.

I have a dedicated linux server in my house, for testing, that I normally have powered down. I wonder if that would suffice, with leaving the Xenforo on the provider and maybe just the elasticsearch running on the (turned on) home server? I do have 175/175 fiber at home.

"It is not possible to install it server-wide as that feature is not offered on our shared hosting. It may be possible to install it within your account however they would need to provide the instruction on how to do this. Other users have tried in the past and they were not able to get it functioning properly.
The other option to use this feature would be to upgrade to a VPS package so you have control over custom software on the server."


Staff member
Hi Mike,

I suggest you upgrade to VPS. Which web host are you using?



I'm on MDDHOSTING as a reseller, with many sub accounts (2 of them Xenforos) It would be so much pricier to move them to VPS's individually. It sounds like Knownhost has great support like my current provider. Knownhost is cheaper initially, but mddhosting includes everything in the price (jetbackup, cpanel, litespeed, etc) so it actually comes out cheaper if you figure in those things.

I've read on the XF forum that some folks seem to put the elasticsearch on a different machine/shell, from the forum. I may need to look into that, if it is practical to do so. I'm only interested in using it for one forum, and it only has 1.1 million posts. I'm not having any speed issues, but it would be nice to be able to search for smaller words and get around the sql limitations